problem with integrating easyEditor with Geoportal

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

problem with integrating easyEditor with Geoportal

ikatinass
This post was updated on .
Hello again,
So smartEditor is working on its own, as wel as geoportal but now I got a problem with integrating easyEditor with Geoportal.
I was following http://52north.org/images/stories/52n/communities/metadata/documents/52n%20smarteditor%20configuration%20guide%201.2%20to%20geoportal%20server.pdf
however once i finished necessary configurations there was no difference in geoportal user interface (no smartEditor link was available as it sould be by default). So I replaced the existing Geoportal internal metadata editor with smartEditor and this is the result I got:


I provide logs for smartEditor
smarteditor-webapp.log

and geoportal
gpt.2012-07-27.log

Firebug gives me:
 ReferenceError: sdisuite is not defined
var sdisuiteUrl = sdisuite.smartEditor;

I also noticed that smarteditor logs contains information about bad database configuration, however I manage to succesfully save templates in the databse, saves_templates table

What could be the problem?
Best regards and Thank you,
Irmantas
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem with integrating easyEditor with Geoportal

ikatinass
This post was updated on .
so it suddenly started to work, I'm not sure but I think it helped that I uncommented the following:


 
  <parameter key="sdisuite.integrationType" value="dialog"/>

I didn't tried that before since I use geoportal v 1.2.2
Loading...