unable to run standalone smartEditor 1.2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

unable to run standalone smartEditor 1.2

ikatinass
This post was updated on .
Hello,
I have a task to integrate smartEditor with Geoportal. However I am unable to setup standalone smartEditor 1.2 in the first place. I am using Tomcat 6 as a servlet container, JDK 1.6 and PostgreSQL 8.4 as a database. I have deployed smartEditor, Prepered database by creating 2 tables on a default postgres DTB using provided script, implemented JDBC Database Driver - postgresql-8.4-703.jdbc4.jar, modified server.xml with the following code:

 <GlobalNamingResources>
        <Resource name="editor" auth="Container" type="javax.sql.DataSource"
                                maxActive="100" maxIdle="0" maxWait="10000"
                                defaultAutoCommit="false"
                                username="postgres" password="postgres"
                                driverClassName="org.postgresql.Driver"
                                url="jdbc:postgresql://localhost:5433/postgres"/>
  </GlobalNamingResources> 

By now I expect to see at least some User Interface of easyEditor since in the installation guide - Apache Tomcat Servlet Container is used as a default one. However all I am getting is exception errors:

javax.servlet.ServletException: Servlet.init() for servlet dispatcher threw exception
        org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
        org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
        org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:602)
        org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
        java.lang.Thread.run(Unknown Source)

root cause

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'dictionary' defined in ServletContext resource [/WEB-INF/dao-definitions.xml]: Invocation of init method failed; nested exception is java.util.MissingResourceException: Can't find bundle for base name /isolist, locale en-gb
...
I included the full log file in the attachment.
smarteditor-webapp.log

Does anybody have Ideas why, where and what is the problem?

As i googled I only found something about locale.default=en-GB and case sensitivity, but in that case I wouldn't be the only one to experience this problem

Is  there some problems with my installation, or is it something else? I am too raw at all this, so at least what I need is some guidance - which direction to go.
Any help would be appreciated, thank you.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: unable to run standalone smartEditor 1.2

ikatinass
O.K.

found the problem...
I'm not that bright at this to explain why, but apparently I had to rename
\Tomcat 6.0\webapps\smarteditor-webapp-1.2\WEB-INF\classes\isolist_en.properties
to
\Tomcat 6.0\webapps\smarteditor-webapp-1.2\WEB-INF\classes\isolist.properties
or to
\Tomcat 6.0\webapps\smarteditor-webapp-1.2\WEB-INF\classes\isolist_en-gb.properties
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: unable to run standalone smartEditor 1.2

Kristian Senkler
Hi there,

this problem occurs if you run the smarteditor with a locale different from "en". During runtime, the application picks the property file related to your request language given by the browser settings. If you locale is set to "en" and you have a file called "isolist_en.properties" everything is fine. If your locale is "fre", a file called "isolist_fre.properties" is searched and, in that case, an error is yield.

The workaround you did is perfectly right. By providing a file without any locale suffix (i.e. isolist.properties) you tell the application to always pick this one as a default language in case no matching file was found.

I will consider this issue in the next smartEditor update to make it more easy.

Cheers,
Kristian

-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von ikatinass
Gesendet: Donnerstag, 26. Juli 2012 15:35
An: [hidden email]
Betreff: Re: [Metadata] unable to run standalone smartEditor 1.2

O.K.

found the problem...
I'm not that bright at this to explain why, but apparently I had to rename \Tomcat 6.0\webapps\smarteditor-webapp-1.2\WEB-INF\classes\isolist_en.properties
to
\Tomcat
6.0\webapps\smarteditor-webapp-1.2\WEB-INF\classes\isolist.properties
or to
\Tomcat
6.0\webapps\smarteditor-webapp-1.2\WEB-INF\classes\isolist_en-gb.properties




--
View this message in context: http://metadata.forum.52north.org/unable-to-run-standalone-smartEditor-1-2-tp4011920p4011921.html
Sent from the 52°North - Metadata Management Community Forum mailing list archive at Nabble.com.
_______________________________________________
Metadata mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/metadata
_______________________________________________
Metadata mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/metadata
Loading...